Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Load report failed error

I developed a vb console app that loads a report and export to pdf and emails it. It works fantastic on my development system.

Assemblies on my machine are Engine, ReportSource, & Shared all 13.0.2000.0 for x86.

I compiled with target cpu of x86.

On the clients server 2008 machine I installed the code into the programs (x86). I also installed the vs2010 redistributable 32 on their 64 bit server. The SAP Crystal Reports runtime engine for .net Framework 4 (32-bit) has a version of

I get this error every time I try to execute the following vb code: reportDocument.Load(Me.crystalReportSource) where _reportDocument is declared as Private _reportDocument As New ReportDocument and _crystalReportSource is a string.

Load report failed.

at CrystalDecisions.ReportAppServer.ReportClientDocumentWrapper.EnsureDocumentIsOpened()

at CrystalDecisions.CrystalReports.Engine.ReportDocument.Load(String filename, OpenReportMethod openMethod, Int16 parentJob)

at CrystalDecisions.CrystalReports.Engine.ReportDocument.Load(String filename)

I've added Network Service to c:\temp and c:\windows\Temp.

I've tried loading the 64bit runtime and recompiled as 64, (however, the compiler still uses the 32 bit assemblies in the compile).

The client got really desperate and purchased Crystal 11 and installed on the server as well. I noticed those libraries are at 10.x

They are functionally shutdown due to their server being switched to 64bit and Crystal not running due to this problem, (all this worked great on the old 32bit workstation they used as a "server").

Please Help



All the troubleshooting steps for 'Load report failed' are [here|].

Also take a look at this search [|]



0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question