Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Error while running WDJ application using jxl.jar

Hi Experts,

I am using jxl.jar in my webdynpro java application in CE7.2. I added jxl.jar in java build path and place the jar file in lib directory of webdynpro DC. It shows error in development configuration perspective while building, then i created another DC of type ExternalLibrary and added jxl.jar in libraries folder, then i right click on that jar and published as archive. Then in Development configuration perspective i added ExternalLibrary project to my webdynpro DC, it doen't shows error while building.

I deployed successfully, when i run the application, it shows the following error. Is there any fault in adding external jar to mt DC? i can't understand where the problem is?

Error:

java.lang.ClassNotFoundException: jxl.Workbook -


Loader Info -


ClassLoader name: [com.drl.bomrecipe/bomrecipe] Loader hash code: 30a86ee9 Living status: alive Direct parent loaders: [system:Frame] [interface:webservices] [interface:cross] [interface:security] [interface:transactionext] [library:webservices_lib] [library:opensql] [library:jms] [library:ejb20] [service:p4] [service:ejb] [service:servlet_jsp] [sap.com/tcwdapi] [library:tcblexceptionlib] [library:tcblloggingapi] Resources: E:\usr\sap\CE7\J00\j2ee\cluster\apps\com.drl.bomrecipe\bomrecipe\servlet_jsp\webdynpro\resources\com.drl.bomrecipe\bomrecipe\root\WEB-INF\lib\com.drl.bomrecipe~bomrecipe.jar -


at com.sap.engine.boot.loader.MultiParentClassLoader.loadClass(MultiParentClassLoader.java:272)

at com.sap.engine.boot.loader.MultiParentClassLoader.loadClass(MultiParentClassLoader.java:241)

at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:367)

help me please, thanks in advance

Regards,

Pradeep Kumar G

replied

Hi Pradeep,

Have you created both compilation and assembly public parts for your Ext Lib, and have you added them both to your Used DC's list?

Also remember, since you are using an assembly public part, the 'Create Archive' and 'Deploy new archive and run' should not be used!

Use the DC Build and DC Deploy instead.

Hope this helps!

Robin van het Hof

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question