Archived discussions are read-only. Learn more about SAP Q&A

CR Runtime Engine for .NET Framework 4.0 requires Framework 2.0

Hi,

Prior to using the latest release of Crystal Reports I didn't get any errors when compiling my Visual Studio 2010 installation project but since the CR upgrade I keep getting the following error messages:

WARNING: The 'SAP Crystal Reports Runtime Engine for .NET Framework 4.0' item selected requires 'Microsoft.Net.Framework.2.0'. Select the missing prerequisite in the Prerequisites Dialog Box or create a bootstrapper package for the missing prerequisite.
WARNING: The 'SAP Crystal Reports Runtime Engine for .NET Framework 4.0' item selected requires 'Microsoft.Data.Access.Components.2.8'. Select the missing prerequisite in the Prerequisites Dialog Box or create a bootstrapper package for the missing prerequisite.

As per one of the articles I read, I have the following statement in the App.config module:

<startup useLegacyV2RuntimeActivationPolicy="true"></startup>

Even though I get the above error message the package still compiles but when I try to use it to install my package I also get the following error messages:

Installing using command 'C:\Windows\system32\msiexec.exe' and parameters ' -I "C:\Users\PC\AppData\Local\Temp\VSD1B4C.tmp\Crystal Reports for .NET Framework 4.0\CRRuntime_32bit_13_0_1.msi" -q '
Will attempt to elevate process.
Process exited with code 1603

I could really use some help here so any comment would be greatly appreciated.

Thanks,

turbo56

Edited by: turbo56 on Apr 14, 2011 11:50 PM

Not what you were looking for? View more on this topic or Ask a question