Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Crystal Reports for .NET Framework 4 SP1 64 bit not installing on Windows 7

HI,

I am getting the following message when trying to install the version 13.0.1 of the Crystal Reports Runtime:

"This software package can only be installed on systems that has installed .NET Framework 2.0 or higher."

The CR file is CRRuntime_64bit_13_0_1.msi (Crystal Reports Runtime for .net 4.0 sp1).

The OS is Windows 7 Ultimate 64 bit Spanish running on a VMWare virtual machine.

The OS has few things installed. The Windows 7 Service Pack 1 is not installed. The .NET 4.0 framework is installed using the full framework redistributable (dotNetFx40_Full_x86_x64.exe and the Spanish language pack dotNetFx40LP_Full_x86_x64es.exe).

In the Add/Remove programs panel control snippet I can see the following entries:

Microsoft .NET Framework 4 Client Profile

Microsoft .NET Framework 4 Extended

Plus the two corresponding Spanish language packs:

Paquete de idioma de Microsoft .NET Framework 4 Client Profile

Paquete de idioma de Microsoft .NET Framework 4 Extended

I get the same error trying to install the 32 bit version of the runtime (CRRuntime_32_bit_13_0_1).

For trying purposes only, I tried to install the previous version of Crystal Reports (The name of the package is CRRuntime_12_3_mlb.msi, I think the official name was Crystal Reports for Visual Studio 2008), and I get a similar error message:

"This software package can only be installed on systems that has instaleld .NET Framework 1.1 or higher".

What am I doing wrong? I thought the .NET 4.0 included all previous versions of the framework.

Do I have to install the .net Framework 2.0?

Not what you were looking for? View more on this topic or Ask a question