Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Error when trying to running application

Hi,

I am completley new to SAP netweaver so please forgive my ignorance.

First I installed SAP Composotion Environment and SAP Netweaver 7.1 both on XP Professional (Service Pack 2). They both installed succesfully.

I then created a sample EJB application which I want to run, to test the installation works.

- I am selecting the index.jsp created.

- Right click and Run on Server

- I choose an existing server (SAP Server <CE1>)

- Then I select my browser

- Then I press finish.

The installation stalls at 7%

Then I insert my username and password

Then I get the following error:

Publishing failed

Error during deployment

Error during deployment:

Can't determine deploy mechanism. Please check if there is a correct default system specified in the SAP System Registry preference page and if this SAP System is currently up and running.

I have tried the following:

Can't determine deploy mechanism

but this does not solve the problem

The Deploy View console gives the following output: (X=error, I=information)

X Port: -1

X Host: computer

X The host or port returned by the SAP System Registry is invalid:

I Looking for Deploy Controller deploy mechanism...

I SDM port not defined or not found

I Found SDM host: computer

I Checking for SDM host..

I [001]Start deployment

I have also looked here Installation however this resource dosen't seem very useful.

Regards,

Steve

Not what you were looking for? View more on this topic or Ask a question