Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Proxy Run time error

Hi PI Gurus

We have upgraded from R3 4.7 to ECC 6.0 and XI3.0 to PI 7.1. Everything works fine but for one interface using File to Proxy on ECC. This interface fails with error message shown below:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!--

Call Inbound Proxy

-->

- <SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="">

<SAP:Category>XIProxy</SAP:Category>

<SAP:Code area="ABAP">PARSE_APPLICATION_DATA</SAP:Code>

<SAP:P1>Request Message</SAP:P1>

<SAP:P2>CX_ST_MATCH_ELEMENT</SAP:P2>

<SAP:P3>/1SAI/TXS6AADED145A656E30E322 Line 521</SAP:P3>

<SAP:P4>System expected the element '{<NameSpace>}MT_VINAtrbOutbound' XML Bytepos.: 128 XML Path: ns0:MT_VINAtrbOutbound(1)</SAP:P4>

<SAP:AdditionalText />

<SAP:ApplicationFaultMessage namespace="" />

<SAP:Stack>Error during XML => ABAP conversion: Request Message; CX_ST_MATCH_ELEMENT in /1SAI/TXS6AADED145A656E30E322 Line 521 System expected the element &#39;{<NameSpace>}MT_VINAtrbOutbound&#39; XML Bytepos.: 128 XML Path: ns0:MT_VINAtrbOutbound(1) System expected the element &#39;{<NameSpace>}MT_VINAtrbOutbound&#39;</SAP:Stack>

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

I have regenerated, activated, deleted, recreated proxy many times. I tested proxy for one set of data and it works fine.

Any ideas? Please help.

Thanks

Rajesh

Former Member replied

Hello Rajesh,

Sorry for the typo!!!

I'm glad it has helped you...

Don't forget the forums rules, poits, etc for usefull answers ...

Happy new year...

Cheers,

Jorge Eidelwein

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question