Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

BAdI /SAPSLL/IFEX_MM0A_R3 does not work with initial transfer of documents

Hello gurus,

we are trying to implement a document transfer to have our purchasing orders etc. checked for partners on a sanctioned party list.

During our tests we had a problem with PO items without a material number. All those items were locked by GTS because they were considered u201Ctechnically incompleteu201D. This was annoying because the material number is not used for sanctioned party list screening anyway.

So we implemented the BAdI /SAPSLL/IFEX_MM0A_R3 so that the material number is set to a default value for all PO items. This solved the problem okay, no new PO was locked any more.

But now we tried the u201CInitial transfer of documentsu201D (in transaction /SAPSLL/MENU_LEGALR3) for existing POs and the error is back! Heaps of items were locked because u201Ctechnically incompleteu201D. It still works for new POs though.

This is strange to me, because I cannot see any difference between automatically transferring a PO to GTS just by saving it and manually transferring them using the given transaction.

Am I missing something here?

Thanks

Alicia

Not what you were looking for? View more on this topic or Ask a question