Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

HTTP 500 Internal Server Error in SXMB_MONI

Hello,

Getting HTTP 500 Internal Server Error while running some Synchronous Scenario of ECC -> PI -> Legacy system (SOAP adapter). Following are the errors received in SXMB_MONI.

<SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">
  <SAP:Category>XIAdapterFramework</SAP:Category> 
  <SAP:Code area="MESSAGE">GENERAL</SAP:Code> 
  <SAP:P1 /> 
  <SAP:P2 /> 
  <SAP:P3 /> 
  <SAP:P4 /> 
  <SAP:AdditionalText>com.sap.engine.interfaces.messaging.api.exception.MessagingException: java.io.IOException: invalid content type for SOAP: TEXT/HTML; HTTP 500 Internal Server Error</SAP:AdditionalText> 
  <SAP:Stack /> 
  <SAP:Retry>M</SAP:Retry> 
  </SAP:Error>

<SAP:Error xmlns:SAP="http://sap.com/xi/XI/Message/30" xmlns:SOAP="http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">
  <SAP:Category>XIServer</SAP:Category> 
  <SAP:Code area="INTERNAL">CLIENT_SEND_FAILED</SAP:Code> 
  <SAP:P1>500</SAP:P1> 
  <SAP:P2>Internal Server Error</SAP:P2> 
  <SAP:P3>(See attachment HTMLError for details)</SAP:P3> 
  <SAP:P4 /> 
  <SAP:AdditionalText /> 
  <SAP:Stack>Error while sending by HTTP (error code: 500 , error text: Internal Server Error) (See attachment HTMLError for details)</SAP:Stack> 
  <SAP:Retry>N</SAP:Retry> 
  </SAP:Error>

Both the errors are not regular but comes up every now and than. If the scenario is re-run from ECC than it works.

Please advise.

Thanks a lot

Former Member
Not what you were looking for? View more on this topic or Ask a question