Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

MaxDB Database Startup Error

The maxDB database is not starting,

When I type

dbmcli -n mgiusdgrc1 -d CME -u superdba,<passwd> db_online, I get the following error.

Error! Connection failed to node <hostname> for database CME:

-24700, ERR_DBMSRV_NOSTART: Could not start DBM Server.

-24832, ERR_SHMNOTAVAILABLE: Shared memory not available.

-24827, ERR_SHMALLOCFAILED: ID E:\sapdb\data\wrk\CME.dbm.shi, requested size 260010,

Opening shared memory file E:\sapdb\data\wrk\CME.dbm.shi failed, rc = 5.

I tried to rename the file CME.dbm.shi, but it did not work.

Currently we have 8 GB of physical memory RAM allocated on Wndows 2008 Server and paging size specified is 16 GB.

1- Can anyone help in resolving the above shared memory error?

2- Are there any logfiles and specific error messages that I need to check, to resolve the MaxDB startup issue error.

Thanks in advance.

Former Member
replied

> I executed C:\ dbmcli -U c_J2EE db_online and got the same error message as before.

which one? the shared memory or the xuser error message?

It seems to me that the user running the database is not permitted to create a shared memory segment. This may be caused by the UAC which (sometimes) has some nifty side effects.

You can switch the UAC off by

- start - execute - msconfig

- last tab

- scroll down to "disable UAC"

- reboot

Markus

1 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question