Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Export to excel. Subreport blank rows generated.

Dear Forum

Hoping you can help with a query.

I have a report that has 3 subreports all are supressed if blank and not shown during preview or print.

When i try and export the report to excel the returning result is a series of blank rows in excel.

I know the subreports are the root cause of the issue as when each of them is supressed my blank row count reduces accordingly.

Is this a know issue or is there indeed a resolution.

Thank you forum for your assisatnce as ever

With Kind Regards

Paul Marks

Former Member replied

Hi Paul,

Sorry to be a downer but It has been my experience that the more complex a report is the more problems I have when exporting especially to excel.

Below is a link to the export limitations of Crystal 10...I haven't found a newer version for XI or 2008. This document doesn't give an exact explanation for each limitation but sometimes it's enough to know that there is an issue related to exporting your report. In your case there are limitations related to exporting suppressed items to an excel spreadsheet.

[Crystal Reports 10 - Export Limitations|]

I don't know how much data you have but my suggestion is to try exporting your report to a csv file instead because suppression is not as much a problem when exporting to that format. CSV files can be opened directly by Excel you are just missing any nice formatting.

If you need a nicely formatted spreadsheet, create a standalone spreadsheet formatted the way you want and either paste in the data from your exported Crystal report or link to the data in the csv file. I have found this type of conversion takes a little longer to set up but is much easier to maintain.

If you do decide to export to csv format i must also suggest that the report be formatted for export (this also helps with data dumps to excel):

1. Start rows of data at the left most margin and align any subsequent rows with this position.

2. Make sure the next column (to the right) always starts where the last column ends. This ensures no blank columns get inserted between your data. Subsequent rows should have columns aligned in size and count to ensure proper layout.

3. Make sure all objects in a row have the exact same height and use the "fit to section" command to prevent extra rows from being generated.

4. Suppress all sections that do not contain any objects needed in your export.

5. If your data isn't too wide (less than 256 bytes but it can be more if the printer driver used can print at a high dpi setting) consider using a formula to create each row of data i.e. properly padded for space delimited or with the commas where you want them for csv etc). This also gives you more control on how each data type is formatted.

Sorry to be so long winded but I hope this helps with your exporting.


0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question