Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Web Service transported with NWDI did not deploy in productive system

Hello experts

I am having some problems transporting an J2EE application(using NWDI) which expose a webservice by using EJBs.

In DEV environment works fine.

In NWDI, I have passed for check-in, development, consolidation, assembly, approval steps and everythings is ok.

When I check the webservice at PRD(production) it does not exist.

Webservice's name is CallCenterIntegratorWS.

This is the log:

20100409172802 Info :Apr 9, 2010 5:27:59 PM Info: Begin of log messages of the target system:

20100409172802 Info :10/04/09 17:27:57 - ***********************************************************

20100409172802 Info :10/04/09 17:27:57 - Start updating EAR file...

20100409172802 Info :10/04/09 17:27:57 - start-up mode is lazy

20100409172802 Info :10/04/09 17:27:57 - EAR file updated successfully for 94ms.

20100409172802 Info :10/04/09 17:27:57 - Start updating...

20100409172802 Info :10/04/09 17:27:58 - EAR file uploaded to server for 578ms.

20100409172802 Info :10/04/09 17:27:59 - Successfully updated. Update took 610ms.

20100409172802 Info :10/04/09 17:27:59 - Deploy Service status:

20100409172802 Info :10/04/09 17:27:59 - Application : gromero.sd/k300~zdc_wd_ctg

20100409172802 Info :10/04/09 17:27:59 -

20100409172802 Info :10/04/09 17:27:59 - gromero.sd/k300~zdc_wd_ctg - WEBDYNPRO

20100409172802 Info :10/04/09 17:27:59 - ***********************************************************

20100409172802 Info :Apr 9, 2010 5:27:59 PM Info: End of log messages of the target system.

20100409172802 Info :Apr 9, 2010 5:27:59 PM Info: ***** End of SAP J2EE Engine Deployment (J2EE Application) *****

20100409172802 Info :Apr 9, 2010 5:27:59 PM Info: Finished successfully: development component 'k300/zdc_wd_ctg'/'gromero.sd'/'ND1_K300TRK_C'/'253128'/'8', grouped by

20100409172802 Info :Apr 9, 2010 5:27:59 PM Info: Starting to save the repository

20100409172802 Info :Apr 9, 2010 5:28:00 PM Info: Finished saving the repository

20100409172802 Info :Apr 9, 2010 5:28:00 PM Info: Starting: Update: Selected software component 'ZSC_K300'/'gromero.sd'/'ND1_K300TRK_C'/'1000.1.0.0.0.20100409222606''/'0' updates currently deployed software component 'ZSC_K300'/'gromero.sd'/'ND1_K300TRK_C'/'1000.1.0.0.0.20100409220642''/'0'.

20100409172802 Info :Apr 9, 2010 5:28:00 PM Info: Finished successfully: software component 'ZSC_K300'/'gromero.sd'/'ND1_K300TRK_C'/'1000.1.0.0.0.20100409222606''/'0'

20100409172802 Info :Apr 9, 2010 5:28:00 PM Info: Starting to save the repository

20100409172802 Info :Apr 9, 2010 5:28:01 PM Info: Finished saving the repository

20100409172802 Info :Apr 9, 2010 5:28:01 PM Info: J2EE Engine is in same state (online/offline) as it has been before this deployment process.

20100409172802 Info :Apr 9, 2010 5:28:01 PM Info: -


Deployment was successful -


20100409172802 Info :end of log

20100409172802 Info :RC of deployment: 0

20100409172802 Info :Step SDM-deploy ended with result 'success' at 2010-04-09 17:28:02.0251 -5:00

Please I would be more than pleased if anyone can help me.

Juan P.

Former Member
Not what you were looking for? View more on this topic or Ask a question