Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Cannot get Web Dynpro app to work??!

Hi All,

I am currently working on a web dynpro app and am having some very annoying issues. I have created a web service using EJB and have published it successfully with java persistence and JPA. I am having issues when trying to Develop the Web dynpro interface for the from end within NWDS 7.2, the steps I have taken already are listed below:

1. Successfully created a Web service.

2. Using JPA have added java persistence for use with the web service.

3. Then put the output of the entries into a table using the web service and Visual Composer, so I know the Web Service and Data are correct and working.

4. I have then been trying to create a Web Dynpro interface within 7.2 for this and this is what i did,

a. I created a new Web Dynpro Project.

b. I then added the We Service Modal to it.

c. I then imported the Web Services Modal into the context of the Componant Controller using the Apply Template (Service Controller) Method.

d. I then created a data link to my main view and carried across all the context attributes that i wanted to display.

e. Then I applied a Template to the main view of type Table and selected the nodes that I wanted in the table.

f. Then I ran and deployed this without added any code or changing any code and it successfully deployed however the table displayed and was empty.

g. Then I tried adding the code below to the Context Controller to see if that would work, however the table did not display and I got a large error report.

public void wdDoInit()
  {
    //@@begin wdDoInit()
	  NewAWS1Model model = new NewAWS1Model();
	  ReadAllClientsResponse responseCloud = new ReadAllClientsResponse(model);
	  List list = null;
	  responseCloud.setReturn(list);
	  wdContext.nodeReadAllClientsResponse().bind(responseCloud);
	  //wdContext.nodeReadAllClientsResponse().bind(new ReadAllClientsResponse(model));
	  
    //@@end
  }

I presume I am missing some code or am not creating the code correctly, this is really annoying me as i know all the other parts work ok however i cannot display the entries. Just also to note the web service i am trying to call is designed to pull all table entries and requires no input. I hope someone can help me with this. Thanks

Edited by: anixan on Apr 12, 2010 9:03 AM

Edited by: anixan on Apr 12, 2010 9:41 AM

Former Member

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question