Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Date type range parameter does not update parameter values in BOE schedule

Hello All,

Please help me out with the following scenario:

1. Created a Crystal Reports against an SAP ECC table

2. Create a static date type range parameter

2. Added the range parameter to the record selection formula as follows:

<Table Name.Field>={?Para} where Field is also a date type field

3. Ran the report in the CR designer itself and everything worked fine

4. Published the report to Business Objects Edge Standard Server

5. Went into db configuration to set the right credentials and Scheduled the report by hitting on "Run Now". Report ran fine

6. Also ran the report by just opening it up in InfoViewApp and refreshing for new parameter values. No issues in this case either

7. Went into CMC->Selected the report>r-clicked>Schedule>"Parameters'>added the new parameters both from Calendar option and manually-->Clicked on "Add".

Issue: The existing parameter values do not change to the new ones on clicking on "Add"

Changed the "Range" option in Crystal Reports to "False" in the same report and republished it and followed all the above steps. No issue found in this case. Parameter values get updated and report can be scheduled without any issue.

Also, tested out string type parameters and didn't come across any issues.

Here is some information about my system setup:

1. Crystal Reports 2008

2. SAP Integration Kit 3.1

3. Business Objects Edge Standard 3.1

4. SAP ECC 6.0 or higher

Has anybody else run across a similar issue?

Thanks a lot!

Gaurav

Former Member
Not what you were looking for? View more on this topic or Ask a question