Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

An error has occurred while attempting to load the Crystal Reports runtime.

I recently upgraded my webserver from a IIS 5.0 to IIS 7.5. On my website I have an application that runs a Crystal Report that was developed in Visual Studio 2005. Initally the Crystal Report would not work. Then after reading a bunch of forumn posts I made a change to the application pool to allow 32 Bit applications to run. This initially solved the problem.

Of course I was having another problem with one of the web services we created. I had the developer of the server take a look and he made a few changes to IIS and eventually got the service to run. Not sure what changes he made. That's the problem. The next day I noticed that the Crystal reports are once again giving the same error message they were giving before I made the change listed above. So what's the problem now. I look at the application pools and they're all set to allow 32 bit apps. Now I've ready another bunch of posts on this error and nothing is working for me. I'm reasonably certain it's some sort of permission problem but I don't really know what to go check. The error I'm getting is show below. Anybody have any ideas?

Server Error in '/' Application.

-


An error has occurred while attempting to load the Crystal Reports runtime.

Either the Crystal Reports registry key permissions are insufficient or the Crystal Reports runtime is not installed correctly.

Please install the appropriate Crystal Reports redistributable (CRRedist*.msi) containing the correct version of the Crystal Reports runtime (x86, x64, or Itanium) required. Please go to http://www.businessobjects.com/support for more information.

Former Member
replied

Well, if it is runtime, let's get the correct runtime there. To do that, we'll need to know what version CR runtime the app is using. Once you give me that info, I'll let you know how to get the correct runtime.

If it is permissions, you'll need to run a utility like [Process Monitor|http://technet.microsoft.com/en-ca/sysinternals/bb896645.aspx] and see what it tells you.

Finally, are yo not able to get hold of the "developer of the server" and find out what he did?

Also, are you the developer of this app?

Ludek

Follow us on Twitter http://twitter.com/SAPCRNetSup

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question