Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

NWDS 7.2 Trial installation runs endless

Hi,

I installed NWDS 7.2 on Windows 7 (32 Bit).

Everything looks fine, until the point the ide tries to install the downloaded sap plugins.

After ~ 27% Percent of installation, the ide runs unending trying to install feature file:feature.xml

I receive no error, it just runs never-ending.

Can anybody help - I also tried it with windows xp professional, with the same result.

My log in the workspace folder looks like this:

!SESSION 2010-04-07 09:53:22.909 -


eclipse.buildId=I20080617-2000

java.version=1.6.0_18

java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en

Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY com.sap.mi.fwk.dcfwk 4 0 2010-04-07 09:54:08.864

!MESSAGE

!STACK 0

org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: com.sap.ide.dii05.facade; bundle-version="0.0.0"

at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305)

at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:355)

at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1074)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:616)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:299)

at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:489)

at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:211)

at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:321)

!ENTRY com.sap.ide.jvm.check 1 0 2010-04-07 09:57:54.257

!MESSAGE JVM Version Check succeeded.

!ENTRY com.tssap.util.ui 1 0 2010-04-07 09:57:55.380

!MESSAGE Sap NetWeaver Developer Studio - Platform Feature Version: 8.20.10001.091216134426

Thank you!

Thomas

Former Member
Former Member replied

Hallo Thomas,

I hope this does not come late. I had the same Problem. In fact I found your question searching for "NWDS 27%" :-D

The problem I identified with my installation was that the Adobe Lifecycle Designer was installed from a previous NWDS 7.0 installation. The way I found out was the following:

When the installation freezes, have a look at the following file:

eclipseconfigurationorg.eclipse.updateerror_recovery.log

I think shows the component it is trying to install at the very last line.

In my case as I said it was some feature from Adobe:

com.sap.netweaver.developerstudio.ald_10.0.0.100212092815

I had a look into the folder of this feature and found a MSI (Microsoft Installer) file there. When I executed it, the installer gave me the exception, that an older version of ALD had to be deinstalled first.

It looks like the update procedure runs different msi files in the background and when there is a user input required, it freezes.

After deinstalling the SAP WebDynpro Form Design Control, I could install past the magic 27%

But then it would stop at 31% which drove me 31% insane. This time I knew where to look and found the SAP Graphics Chart Control to be the trouble maker.

So I uninstalled the both of them and startet a clean install and it finished sucessfully.

Viel Gl├╝ck

Matthias

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question