Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Open Document Token

Hello,

I am able to run a report without logging into CMC. I used opendocument .net web site. However, when I attach the token, the prompt values don't get passed.

The prompt value work when I don't pass the token, but when I append the token they don't work.

For example:

Case 1

======

http://dep-bo/OpenDocument/opendoc/opendocument.aspx?sKind=FullClient&sType=rpt&iDocID=3653&lsMSelect+Counties=Somerset;Atlantic

In the above case, I am not passing the token. I am prompted to login. After I login, the report is correctly shows results for "Somerset" and "Atlantic" counties. No prompt box comes up (which is want I want".

Case 2

=======

http://dep-bo/OpenDocument/opendoc/opendocument.aspx?sKind=FullClient&sType=rpt&iDocID=3653&lsMSelect+Counties=Somerset;Atlantic&Token=dep-bo.dep.state.nj.us:6400@4082JvNWgWcYEK7e3J4W4080J6fPpVyVnlWiuSmZ

In this second case, I am attaching a valid token. When I do that, I am NOT prompted to login. However, the prompt screen comes up instead of report result. The prompt asks to select the counties. I am passing the counties in the URL.. It should work the same way as Case 1.

Can you help me with this?

I am creating the token this way:

enterpriseSession =

sessionMgr.Logon(strUSER, strPASS, strCMS, strAUTH);

iStore = (InfoStore)enterpriseSession.GetService("InfoStore");

userInfo = enterpriseSession.UserInfo;

strTOKEN =

enterpriseSession.LogonTokenMgr.CreateLogonTokenEx("", 10, 100);

Imran

Former Member
replied

Hello Imran,

There are a few possible issues with both of your OpenDoc URLs. Have you looked at the OpenDocument article that describes OpenDoc parameter syntax? If not, here's the link: [Viewing Reports and Documents using URLs|http://help.sap.com/businessobject/product_guides/boexir31/en/xi3-1_url_reporting_opendocument_en.pdf].

OpenDocument URL parameters are case sensitive. The "token" parameter is lower case. You're using an upper case T.

You're using "sKind=FullClient". This parameter is required for a Full Client document, however there is no corresponding sType document type. Try dropping the "sType=rpt" parameter.

Multiple prompt values for your "lsM" parameter should be separated by a comma, not a semicolon. See page 24 in the OpenDocument article.

For troubleshooting I usually suggest stripping down the URL to the bare minimum. In this case it would be the iDocID and sType URL parameters (since sType is required for FullClient documents). This should prompt for Enterprise logon and parameters. Now add in the valid "token" value. Now this should prompt for just the parameters. Finally, add the lsM[parameter] URL parameter value. Make sure to test with a comma separator, not a semicolon.

Does this help resolve the issue?

Sincerely,

Dan Kelleher

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question