Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

L01 value is not populating correctly

Hi all,

We have a universe based on BEx query. We created a WebI report with that universe.

There is a hierarchy defined in the query which crated dimensions L01 to L11 in the universe.

My understanding is the L01 should have the highest hierarchy for a particular user.

For example, for a country head the L01 should have country and for a District head the L01 should have District when these users run the WebI query.

But when we tried running a webi report with a District head id, the L01 returned his next hierarchy data. But the Bex query returned proper data with this query in the analyzer. It seems that the Designer omits the first level of the hierarchy for all the users and displaying only the next level in the L01.

I dont want to use L00 to solve this issue as it will summarize the data. When the District head has more than one district all he can see is summarized data.

Is this the way this works(omitting first level hierarchy)? or is there anything that can be done to solve this? Please help.

Former Member
Former Member replied

Hi,

For your information, here are details on how SAP maps metadata and especially level L00 '(see attached file).

If you have installed BOE XI3.1 SP2, there is a bug when you uncheck the ioption "do not generate L00 level".

This issue will be fixed in SP3. You can see all details on when the L00 is significant or not in the attcahced file.

So in your case you need to generate L00 level: this is the way that SAP is generating metadata and it is conform to OLAP specifications.

Regards,

Didier

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question