Not able to connect to DB due to SQL2071N error


We restored an SAP BI 7.0 system running on AIX 5.3 and DB2 FixPack 4 64-bit system using UNIX file level restoration on an existing AIX server from a backup media.

After restoration, I changed the hostnames and file permissions and managed to be able to issue "db2start" and "db2stop" successfully for the restored database.

However I am currently facing a problem connecting to the database, eventhough I am able to issue the command u201Cdb2startu201D successfully to start the Database Manager, whenever I try to execute u201Cdb2 connect to DBXu201D, I get the following error:

SQL2071N An error occurred while accessing the shared library

"/usr/tivoli/tsm/tdp_r3/db264/libtdpdb264.a". Reason code: "2".

Iu2019ve done some Googling and some people have had similar issue ( , and they recommended using the command u201Cdb2 update db cfg for DBX using LOGARCHMETH1 offu201D to change the value of LOGARCHMETH1 to u2018OFFu2019. I tried updating the DB CFG parameter value of LOGARCHMETH1 to u2018OFFu2019, but for some reason eventhough the system replied that the update was successful, everytime I retrieve the value of LOGARCHMETH1 again (through "db2 get db cfg for DBX | grep -i log") itu2019s still showing u201CVENDOR:/usr/tivoli/tsm/tdp_r3/db264/libtdpdb264.au201D, even after I tried u201Cdb2stopu201D and u201Cdb2startu201D again.

From this SDN forum thread ( SQL1651N - during Redirect Restore), they recommended to use the program brdb6brt and version recovery method using "without rolling forward" to perform the redirected restore.

My question is, without resorting to another restore/backup:

1. Would enabling TSM on the current setup help?

2. Restoring the missing directory "/usr/tivoli/tsm/tdp_r3/*" on the destination server, would this help?

3. Any other suggestions/ideas on why the parameter change isn't reflected eventhough the system reported that the change was successful? (e.g. "DB20000I The UPDATE DATABASE CONFIGURATION command completed successfully.")


Below are the current parameter values from "db2 get db cfg":

Log retain for recovery status = NO

User exit for logging status = YES

Catalog cache size (4KB) (CATALOGCACHE_SZ) = 2560

Log buffer size (4KB) (LOGBUFSZ) = 1024

Log file size (4KB) (LOGFILSIZ) = 16380

Number of primary log files (LOGPRIMARY) = 20

Number of secondary log files (LOGSECOND) = 40

Changed path to log files (NEWLOGPATH) =

Path to log files = /db2/DBD/log_dir/NODE0000/

Overflow log path (OVERFLOWLOGPATH) =

Mirror log path (MIRRORLOGPATH) =

First active log file = S0005379.LOG

Block log on disk full (BLK_LOG_DSK_FUL) = YES

Percent max primary log space by transaction (MAX_LOG) = 0

Num. of active log files for 1 active UOW(NUM_LOG_SPAN) = 0

Percent log file reclaimed before soft chckpt (SOFTMAX) = 300

Log retain for recovery enabled (LOGRETAIN) = OFF

User exit for logging enabled (USEREXIT) = OFF

HADR log write synchronization mode (HADR_SYNCMODE) = NEARSYNC

First log archive method (LOGARCHMETH1) = VENDOR:/usr/tivoli/tsm/tdp_r3/db264/libtdpdb264.a

Options for logarchmeth1 (LOGARCHOPT1) = /db2/DBD/tdp_r3/vendor.env

Second log archive method (LOGARCHMETH2) = OFF

Options for logarchmeth2 (LOGARCHOPT2) =

Failover log archive path (FAILARCHPATH) = /db2/DBD/log_dir/NODE0000/

Number of log archive retries on error (NUMARCHRETRY) = 5

Log archive retry Delay (secs) (ARCHRETRYDELAY) = 20

Log pages during index build (LOGINDEXBUILD) = OFF

Thank you for your help.

Edited by: Joean Yun on Dec 15, 2009 10:33 AM