Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

RMAN Clone system

Good Day:

I make a copy of system A to the system B using a backup of RMAN, i use the next scrip for it:

Step 1:

Backup include control file and archive log

Step 2:

Drop old database QAS on the SAP instance QAS

Step 3:

I restore the control file from the backup files

Step 4:

I catalog a pieces of backup

Step 5:

I set all the new names for the data files from /oracle/PRD/sapdata1/... to /oracle/QAS/sapdata1/...

I restore my backup DB PRD and rest logs

Step 6:

All is OK!

DB is mounted and open

Step 7:

StartSAP

Ups!!!! SAP dont start.

The log of the R3Trans say:

4 ETW000 R3trans version 6.14 (release 700 - 16.10.08 - 16:26:00).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 26.11.2009 - 11:13:52

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: R3trans -x

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [dev trc ,00000] Thu Nov 26 11:13:52 2009

931 0.000931

4 ETW000 [dev trc ,00000] db_con_init called

155 0.001086

4 ETW000 [dev trc ,00000] create_con (con_name=R/3)

233 0.001319

4 ETW000 [dev trc ,00000] Loading DB library '/usr/sap/QAS/SYS/exe/run/dbo

raslib.so' ...

4 ETW000

286 0.001605

4 ETW000 [dev trc ,00000] load shared library (/usr/sap/QAS/SYS/exe/run/db

oraslib.so), hdl 0

4 ETW000

76790 0.078395

4 ETW000 [dev trc ,00000] Library '/usr/sap/QAS/SYS/exe/run/dboraslib.so' loaded

4 ETW000 429 0.078824

4 ETW000 [dev trc ,00000] function DbSlExpFuns loaded from library /usr/sap/QAS/SYS/exe/run/dboraslib.so

4 ETW000 275 0.079099

4 ETW000 [dev trc ,00000] Version of '/usr/sap/QAS/SYS/exe/run/dboraslib.so' is "700.08", patchlevel (0.167)

4 ETW000 1221 0.080320

4 ETW000 [dev trc ,00000] function dsql_db_init loaded from library /usr/sap/QAS/SYS/exe/run/dboraslib.so

4 ETW000 266 0.080586

4 ETW000 [dev trc ,00000] function dbdd_exp_funs loaded from library /usr/sap/QAS/SYS/exe/run/dboraslib.so

4 ETW000 423 0.081009

4 ETW000 [dev trc ,00000] New connection 0 created 234 0.081243

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = -000000001 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255,

con_opt = 255, occ = NO

4 ETW000 300 0.081543

4 ETW000 [dev trc ,00000] db_con_connect (con_name=R/3) 170 0.081713

4 ETW000 [dev trc ,00000] find_con_by_name found the following connection for reuse:

4 ETW000 246 0.081959

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = 000000000 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255,

con_opt = 255, occ = NO

4 ETW000 286 0.082245

4 ETW000 [dev trc ,00000] Oracle Client Version: '10.2.0.2.0' 1458 0.083703

4 ETW000 [dev trc ,00000] -->oci_initialize (con_hdl=0) 217 0.083920

4 ETW000 [dev trc ,00000] Client NLS settings: AMERICAN_AMERICA.UTF8 42124 0.126044

4 ETW000 [dev trc ,00000] Logon as OPS$-user to get SAPSR3's password 244 0.126288

4 ETW000 [dev trc ,00000] Connecting as /@PRD on connection 0 (nls_hdl 0) ... (dbsl 700 030508)

4 ETW000 299 0.126587

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

4 ETW000 303 0.126890

4 ETW000 [dev trc ,00000] 0 UTF8 1 0x10194f4c0 0x101956f10 0x101967648

4 ETW000 278 0.127168

4 ETW000 [dev trc ,00000] Allocating service context handle for con_hdl=0 310 0.127478

4 ETW000 [dev trc ,00000] Allocating server context handle 204 0.127682

4 ETW000 [dev trc ,00000] Attaching to DB Server PRD (con_hdl=0,svchp=0x101967578,srvhp=0x101969868)

4 ETW000 481 0.128163

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCIServerAttach' failed with rc=12505

4 ETW000 18429 0.146592

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error '12505'

4 ETW000 263 0.146855

4 ETW000 [dev trc ,00000] set_ocica() -> OCI or SQL return code 12505 166 0.147021

4 ETW000 [dev trc ,00000] Try to connect with default password 563 0.147584

4 ETW000 [dev trc ,00000] Connecting as SAPSR3/<pwd>@PRD on connection 0 (nls_hdl 0) ... (dbsl 700 030508)

4 ETW000 294 0.147878

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet C EnvHp ErrHp ErrHpBatch

4 ETW000 272 0.148150

4 ETW000 [dev trc ,00000] 0 UTF8 1 0x10194f4c0 0x101956f10 0x101967648

4 ETW000 273 0.148423

4 ETW000 [dev trc ,00000] server_detach(con_hdl=0,stale=0,svrhp=0x101969868)

4 ETW000 317 0.148740

4 ETW000 [dev trc ,00000] Detaching from DB Server (con_hdl=0,svchp=0x101967578,srvhp=0x101969868)

4 ETW000 262 0.149002

4 ETW000 [dev trc ,00000] Deallocating server context handle 0x101969868 230 0.149232

4 ETW000 [dev trc ,00000] Allocating server context handle 264 0.149496

4 ETW000 [dev trc ,00000] Attaching to DB Server PRD (con_hdl=0,svchp=0x101967578,srvhp=0x101969868)

4 ETW000 289 0.149785

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCIServerAttach' failed with rc=12505

4 ETW000 12261 0.162046

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error '12505'

4 ETW000 258 0.162304

4 ETW000 [dev trc ,00000] set_ocica() -> OCI or SQL return code 12505 163 0.162467

4 ETW000 [dblink ,00431] ***LOG BY2=>sql error 12505 performing CON [dblink#5 @ 431]

4 ETW000 790 0.163257

4 ETW000 [dblink ,00431] ***LOG BY0=>ORA-12505: TNS:listener does not currently know of SID given in connect descriptor [dblink#5 @ 431

]

4 ETW000 283 0.163540

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'PRD'"

HOW I CAN SOLVE IT!???

Not what you were looking for? View more on this topic or Ask a question