Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

verify own hostname <HOSTNAME> failed - Error

Hi All

I recently purchased miniWAS 6.20 and installed the same in my laptop. I am facing some problem. I am able to start the ABAP engine if my system is connected to the internet. But when i do the same without connecting to the Internet the ABAP engine gives me a short dump saying,

<b> Last error logged in SAP kernel

Component............ "NI (network interface)"

Place................ "SAP-Server KATHIR_BSP_00 on host KATHIR (wp 0)"

Version.............. 36

Error code........... "-16"

Error text........... "verify own hostname (KATHIR) failed"

Description.......... "NiIMyAdrVerify"

System call.......... " "

Module............... "nixxi.c"

Line................. 2876 </b>

I did some search and was able to find some solution for the same. The note 824722 gives the following solution,

<b>

Solution

By defining the "gw/local_addr" profile parameter, you can force the system to always use this local IP address for the connection. You can also change the parameter with transaction SMGW in a dynamic way while operating the system. The default value is 0.0.0.0, that is, a specific network adapter is not used.

gw/local_addr = <local IP_adr>

If the IP address specified is not local, the system returns the following error message while establishing the connection:

      • ERROR => NiLowLevCon: NiBind rc = -16

      • ERROR => GwIAsyncConnSend: GwBufConnect to ld0168.wdf.sap.corp / sapgw53 failed (rc=NIEMYHOST_VERIFY)

LOCATION SAP-Gateway on host ldp007 / sapgw11

ERROR verify own hostname (?) failed

TIME Thu Feb 10 13:57:40 2005

RELEASE 640

COMPONENT NI (network interface)

VERSION 37

RC -16

MODULE nixxi.cpp

LINE 3806

COUNTER 2

This parameter is available for 6.40 with CST Patch Collection 08 2005 (patch level 62).</b>

When I goto the transaction <b>SMGW</b> I find a different IP for my machine

<b>

Detailed system information

entry = 0

state = CONNECTED

system type = LOCAL_R3

read channel = -1

write channel = -1

lu = KATHIR

tp = sapgw00

long lu = KATHIR

long tp = sapgw00

ext program = 0

no conversation = 0

appc version = 6

hostaddr [0] = 192.168.20.90

hostaddr [1] = 127.0.0.1

offset in = 0

timeouts in = 0

connected = Mon May 29 10:07:11 2006

last request = Mon May 29 10:07:11 2006

request block number in = -1

connection out = -1

target out = -1

offset out = 0

restlen out = 0

timeouts out = 0

request block number out = -1

accept info = EINFO

snc forced = 0

Own Network Addresses

[192.168.20.90] KATHIR (HOSTNAME)

[127.0.0.1] localhost (LOCALHOST)

</b>

The Host entry I have is

<b>127.0.0.1 KATHIR</b>

I am not able to find the gw/local_addr .

Please tell me how to fix this, so that I can connect to SAP with out connecting to the Internet.

Please help me in this regard.

Thanks

Kathirvel

Message was edited by: Kathirvel Balakrishnan

Former Member

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question