Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Broken DCs in ESS Track when upgraded to JDI SP16

Hi,

Track Information – Name – ESSTrack

Business Package – SAP_ESS Release 100 SP7

WAS 6.40 SP 16

JDI – SP16

We have recently upgraded our JDI from SP11 to SP16. We already had a track configured for ESS SP7 in which we have made MANY CUSTOM MODIFICATIONS which are in production. After the upgrade of the J2EE stack to SP16 we upgraded the Netweaver Developer Studio to SP16 also.

After doing that, we checked out a DC for modifications but we had errors in this. In the investigation we saw that the ESS track still had the reference of the SP11 base SCs. So, we copied the new base SCs (SP16) i.e. the "SAP-JTECHS.sca", "SAP-BUILDT.sca", "SAP-JEE.sca" from usr -> sap -> <instance name> -> SYS ->global -> CMS_CBS -> plug-ins (according to the SAP documentation) into the inbox folder, checked them into the track and imported them to the Development and Consolidation runtime systems. Now these dependent SCs show SP16 which is consistent with the rest of the landscape SP. On doing this, we found that most of the DCs of the SAP_ESS SC were broken. To resolve this issue, we even tried to rebuild all the DCs in the compartment using the “Initialize Compartment” button in the Compartments view, CBS Buildspace Details. Still no positive result.

This break has a very big impact on Freescale as this is the only JDI environment we have and if today something breaks in production we HAVE NO WAY to correct this.

Regards

Jay Kapadia

Former Member
Not what you were looking for? View more on this topic or Ask a question