Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Invoking ORACLE Stored Procedure

Hello guys,

I have an ORACLE stored procedure which I need to invoke. I'm currently unable to invoke the stored procedure since I'm always getting the same error:

com.sap.engine.interfaces.messaging.api.exception.MessagingException: Error processing request in sax parser: Error when executing statement for table/stored proc. 'test.set_pickup' (structure 'STATEMENTNAME'): java.sql.SQLException: ORA-06550: line 1, column 7: PLS-00306: wrong number or types of arguments in call to 'SET_PICKUP' ORA-06550: line 1, column 7: PL/SQL: Statement

I've faced several projects where we needed to invoke stored procedures but these were located in a DB2 or Microsoft SQL Server, and these problems never occured.

The procedure is set to the minimum, and is now only with one input parameter. I had an input and output parameter but for narrowing the problem I've removed the output.

The structure for the stored procedure is the one that is referred by SAP or mentioned thousand of times in this forum:

Statement_name

StoredProcedureName (attribute ACTION)

TABLE

P_TRANSACTION_ID (Attributes isInput, isOutput, type)

For the basics I'm only filling with one statement.

I've read some threads with a similar problem but with no response, or solved but with no suggestion on how they solved it.

Could you please help out?

Kind regards,

Gonçalo Mouro Vaz

Former Member
Not what you were looking for? View more on this topic or Ask a question