Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

HTTP_RESP_STATUS_CODE_NOT_OK - 401 Unauthorized

Hi,

We are working on MQ-XI-BW Scenario. A message posted on MQSeries was taken to Integration Server with an error stating that HTTP_RESP_STATUS_CODE_NOT_OK - Authorization Required .

The error stack with trace level 3 is

- <Trace level="1" type="B" name="CL_XMS_PLSRV_IE_ADAPTER-ENTER_PLSRV">

<Trace level="3" type="T">Channel for adapter engine: RFC</Trace>

- <Trace level="1" type="B" name="CL_XMS_PLSRV_CALL_XMB-CALL_XMS_HTTP">

<Trace level="2" type="T">return fresh values from cache</Trace>

<Trace level="2" type="T">Get logon data for adapter engine (SAI_AE_DETAILS_GET): af.mtx.bwxi</Trace>

<Trace level="3" type="T">URL = http://bwxi:8200/MessagingSystem/receive/AFW/XI</Trace>

<Trace level="3" type="T">User = XIISUSER</Trace>

<Trace level="3" type="T">Cached = X</Trace>

<Trace level="3" type="T">Creating HTTP-client</Trace>

<Trace level="3" type="T">HTTP-client: creation finished</Trace>

<Trace level="3" type="T">Security: Basic authentication</Trace>

<Trace level="3" type="T">Serializing message object...</Trace>

<Trace level="3" type="T">HTTP-client: sending http-request...</Trace>

<Trace level="3" type="T">HTTP-client: request sent</Trace>

<Trace level="3" type="T">HTTP-client: Receiving http-response...</Trace>

<Trace level="3" type="T">HTTP-client: response received</Trace>

<Trace level="3" type="T">HTTP-client: checking status code...</Trace>

<Trace level="3" type="T">HTTP-client: status code = 401</Trace>

<Trace level="3" type="System_Error">HTTP-client: error response=</Trace>

<Trace level="3" type="T">HTTP-client: closing...</Trace>

</Trace>

</Trace>

</Trace>

- <Trace level="1" type="B" name="CL_XMS_MAIN-WRITE_MESSAGE_LOG_TO_PERSIST">

<Trace level="3" type="T">No persisting of message after plsrv call, because of config</Trace>

</Trace>

<Trace level="3" type="System_Error">Error exception return from pipeline processing!</Trace>

<Trace level="1" type="B" name="CL_XMS_MAIN-WRITE_MESSAGE_TO_PERSIST" />

- <!-- ************************************

-->

<Trace level="3" type="T">Persisting message Status = 014</Trace>

<Trace level="3" type="T">Message version 010</Trace>

<Trace level="3" type="T">Pipeline CENTRAL</Trace>

</SAP:Trace>

We are not able to rectify the error.we checked the user name in SM59.It is XIISUSER. what could be the reason for the incorrect messages in SXMB_MONI?

Regards

Sathya

Not what you were looking for? View more on this topic or Ask a question