Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Cannot deploy EAR. There are already active sessions

Hi WebDyn Pro's,

I'm running NW SP14

Sporadically, I cannot deploy my WebDynpro app to the NW server. In NWDS, I indicate to Deploy and run. I get an error in the console indicating:

<b>"Cannot log in. There are already active sessions. Session id 0 An administrator logged in via API /"</b>

I restarted the server and the NWDS workstations but that didn't help. I've had this same error in the past. Usually it goes away. I thought I solved it, but evidently not.

On the NW server, I cannot log into SDM GUI either. I get the same error.

As mentioned above, this error occurs sporadically. I can deploy just fine 50 times. And then all of sudden I start getting this error, even though no one has touched the server.

Thoughts?

Thanks,

Kevin

replied

Hi,

Have you checked if anyone else is actually using SDM to deploy?

There are some quite significant deployment tasks that my basis team perform which will occupy the SDM tool for a long time and stop me and my other developers from deploying anything.

I've also caused this problem myself when my SDM deployment has stalled - I've been deploying a custom B2B .ear file and the deployment has just got stuck in processing for ages. In the end I've had to kill the SDM task from Windows Task Manager but this causes SDM to think someone is still logged in so I've then had to restart the SDM service from the SAP Management Console.

If this is not the case I'd suggest raising it through OSS if you can't find any relevant messages on there.

Hope this helps,

Gareth Ryan.

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question