Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

full qualified host name

Dear All,

We've created a web service from function module in our development server.

When we try to display WSDL, we're getting an access denied error.

http://server01:8001/sap/bc/srt/rfc/sap/Z_test_webserv

When we try to replace server01 with the actual ip address it works.

Also using server01.company.org works.

Parameter is set to

icm/host_name_full = server01

/etc/hosts

192.168.22.24 server01

I try to look at it at RZ11 but it has no option to change the value.

What will be the best way to solve this?

What will be the effect of changing server01 to server01.company.org in the hosts file?

Any help is greatly appreciated. Thanks!

Regards,

Rayel

Former Member
replied

You said icm/host_name_full is set to server01

Now you are saying its not showing any value. Sorry, I am confused.

Go to RZ10>Instance Profile->Extended Maintenance.

Search for icm/host_name_full and use Fully Qualified HOst Name (FQHN). Like you mentioned earlier server01.company.org.

If the parameter is not there , you can create it. But it will take effect only after you restart SAP.

From RZ11 you can only change those parameter which are Dynamic. icm/host_name_full is a static parameter , so you are not getting the option to change it from there.

SAPLOCALHOST may not contain a fully qualified hostname, but there is another parameter SAPLOCALHOSTFULL . You can use FQHN there. Then it should work

https://service.sap.com/sap/support/notes/773830

Edited by: Anindya Bose on Sep 11, 2009 9:56 AM

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question