Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SA Message Port not found during the NetWeaver Installation

Hello

at the Neweaver Installation I get follow error, if SAP try to start the Instance: (Output from dev_ms)

-


trc file: "dev_ms", trc level: 1, release: "640"

-


[Thr 2512] Sat May 13 20:01:35 2006

[Thr 2512] systemid 560 (PC with Windows NT)

[Thr 2512] relno 6400

[Thr 2512] patchlevel 0

[Thr 2512] patchno 105

[Thr 2512] intno 20020600

[Thr 2512] pid 2508

[Thr 2512] ***LOG Q01=> MsSInit, MSStart (Msg Server 1 2508) [msxxserv.c 1671]

[Thr 2512] ***LOG Q0I=> NiPGetServByName2: service 'sapmsSK1' not found: getservbyname_r [ninti.c 505]

[Thr 2512] *** ERROR => MsSCommInit: NiBufListen(sapmsSK1) (rc=NIESERV_UNKNOWN) [msxxserv.c 8878]

[Thr 2512] *** ERROR => MsSInit: MsSCommInit [msxxserv.c 1699]

[Thr 2512] *** ERROR => main: MsSInit [msxxserv.c 5317]

[Thr 2512] ***LOG Q02=> MsSHalt, MSStop (Msg Server 2508) [msxxserv.c 5365]

I think, the big problem is here, that the sapms - Service couldn't found it. The entry of Service Port 3600 is in services file. The OS is Windows 2003.

Thanks for your help.

replied

Hi

looks like the entry in the service file ( ..\drivers\etc) is incorrect.Double check the instance number. it should be like

<service name> <service number>/<protocol>

eg: sapmsPRD 3601/tcp ( 01 instance number )

check whether the lookup for specified service name is possible for that port number.

use this command

niping -v -S <service name>

Thanks

Prince

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question