Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

InfoSpoke using BADI dumping while activation; unable to make any changes

Hello Gurus,

I am facing problems in changing an InfoSpoke using BADI. I was trying to make some changes in the selection tab. I wanted to put a selection on the material group.

1. When I made changes to selection and activate the InfoSpoke, it short dumped with Message type X.

2.So I unchecked the BADI ubder Transform to disconnect the infospoke from BADI and tried to activate it. Then too it is dumping.

3.I removed the selection and checked the Transform to bring back to original,then too it is dumping.

4.Now I don't have the original as well.

When icheck the BADI Implementation and Class. Both are active.

How do I correct this. Please help.

Are there any steps to follow to add new selection criteria?

Thanks in advance!!

simmi

replied

Hello Simmi,

I also faced similar problem when tried to make some changes in the infospoke with BADI. I deleted the BADI implementation while detaching it from Infospoke and it worked. You should have got that prompt, I am not sure why that didn't happen in your case. As you have the infspoke and related BADI, my advice would be to create a new infospoke by copying it and make the required changes there before attaching the BADI. Activate it and then include BADI. Code for BADI, you can copy from old one.

Hope it helps.

Regards,

Praveen

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question