Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

is nw 2004s j2ee engine built with JDK 1.4?

i am currently running NetWeaver 2004 WAS 6.40 J2EE Engine SP14. from the version.txt file, i see this line:

Build java version:1.3.1_12-b03 Sun Microsystems Inc.

i understand that during installation of j2ee engine i can specify jdk versions such as 142_09 etc. but i have a specific issue with the dbpool service provided by the j2ee engine. since the engine is itself built with jdk 1.3.1, it doesn't and couldn't support some of the jdbc apis introduced since jdk 1.4.

so i'd like to know which version of j2ee engine starts to be built with jdk 1.4?

if anyone has nw 2004s installed, could you pls check your version.txt file and let me know what the "Build java version" is?

kind regards,

wentao

Former Member
Former Member replied

Hello Wentao,

NW2004s is also built with JDK 1.3.1.

Best Regards

Vyara

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question