Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Crystal Reports XI fails to install

The following error keeps occurring when I try to install our Crystal Reports XI. We are actually getting this error on a couple machines, and Iu2019ve tried all of the things listed on the following pages in order to solve the problem, but to no avail:

CR XI Installation Error 1904

Error 1904 during install of Crystal Reports XI

Error 1904 during the Installation

Crystal Reports XI Merge Module Error

This is the Error we are receiving:

"Error 1904. Module C:\Program Files\Business Objects\BusinessObjects Engerprise 11\win32_x86\plugins\auth\secLDAP\secldap.dll failed to register. HRESULT -2147024770. Contact your support personnel." Abort, Retry, Ignore

These are the things Iu2019ve tried in order to correct the problem:

u2022 When trying to uninstall: Successfully uninstalled. Error still occurs upon installation.

u2022 Deleted all Business Objects folders/files and tried re-installing and choosing "Ignore" when the error occurs. Then I tried running regsvr32 manually on u201Csecldap.dllu201D: regsvr32 fails with the following error message u2013 "LoadLibrary("secldap.dll") failed - The specified module could not be found."

u2022 I checked Data Execution Prevention (DEP) setting and it is set as u201CTurn on DEP for essential Windows programs and services onlyu201D as was suggested: Error still occurs upon installation.

The account Iu2019m logged into when attempting the installation also has Full Administrator Rights.

System Information:

u2022 Administrator Privileges

u2022 Windows XP Pro, Service Pack 3

u2022 All Microsoft .NET Frameworks installed and up-to-date

u2022 The installation should not be corrupted as we are using the CDu2019s we purchased. It is worthy to note that the Merge Modules I downloaded for Crystal Reports also fail to install due to this same error.

I checked the hard drive and interestingly enough the secldap.dll does get placed on the drive midway through installation, so the secldap.dll does exist.

There should be no u201Calias copiesu201D of the DLL because I manually removed any files and folders that the Crystal Reports uninstaller left behind. Iu2019m at a loss as to what to do next to get Crystal Reports installable on these machines. Anything you could suggest would be greatly appreciated. Thanks!

Not what you were looking for? View more on this topic or Ask a question