Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

ValueMappingReplication

<body><p>Hi All,</p><p></p><p>I'm trying to set up Value mapping replication from a custom table in an ERP 6.0 ABAP system into my PI 7.1 system.</p><p>I've followed Udo Martens excellent blog ( &#91;https://www.sdn.sap.com/irj/scn/weblogs?blog=/pub/wlg/13812&#93 <b>[original link is broken]</b> <b>[original link is broken]</b> <b>[original link is broken]</b>; ), but I'm not having any success.</p><p>a) The Value mapping cache is not updated.</p><p>b) I get no messages in SXMB_MONI in PI.</p><p>c) When I test service ValueMappingReplicationOutSynchronous in SPROXY from ERP, I get error message &quot;INTERNAL.SYSTEM_NOT_CONFIGURED_AS_XMB System not configured as XI Integration Engine&quot;</p><p>d) When I execute the synchronous method from ERP I get a variety of faults returned in the catch - such as &quot;<span __jive_macro_name="O"></span>&quot;. Strangely, every time I run it, I get a different number.</p><p></p><p>Several questions come to mind;</p><p>1) Are there any objects that I need to set up in the ERP system - for example RFC's, logical ports etc. (I have set up a logical port for the proxy class)</p><p>2) In the I/B configuration, my receiver is a business system representing the PI system. Is this the Java stack or the ABAP stack (I've tried both).</p><p></p><p>Any help is greatly appreciated.</p><p></p><p>Thanks,</p><p></p><p>Guy</p></body>
Not what you were looking for? View more on this topic or Ask a question