Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

does not map (SOAP -> JDBC)

Hi,

request message mapping at the pipeline, does not map.

please guide me

Source MT Target MT

MT_Dotnet_Out 1:1 MT_Dotnet_Material04_In

MATNO state1 0..unbounded

MATTEXT

MT_Dotnet_Out --> state1

Test IN Message Mappin was ok, but it did not map at the SXMB_MONI

payload of Inbound Message

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Inbound Message

-->

- <m:MI_Dotnet_Async_Out xmlns:m="http://sapxi.aaa.net/pattern/ws2jdbc" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/">

<MATNO>898989</MATNO>

<MATTEXT>XMLSPY</MATTEXT>

<MTART>100</MTART>

<MATKL>200</MATKL>

<MEINS>TON</MEINS>

</m:MI_Dotnet_Async_Out>

payload of request message mapping,

<?xml version="1.0" encoding="UTF-8" ?>

<ns0:MT_Dotnet_Material04_In xmlns:ns0="http://sapxi.aaa.net/pattern/ws2jdbc" />

regards

Venjamin

Former Member
replied

hi,

1. check this weblog how to test your mappings

/people/michal.krawczyk2/blog/2005/09/16/xi-how-to-test-your-mapping-in-real-life-scenarios

2. check in SXMB_MONI if the mapping program

(interface mapping) was found

3. check your scenario in ID if you supplied

a correct interface mapping in your scenario

Regards,

michal

-


<a href="/people/michal.krawczyk2/blog/2005/06/28/xipi-faq-frequently-asked-questions">XI / PI FAQ - Frequently Asked Questions</a>

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question