Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

RFC_ADAPTER "APPLICATION_ERROR"

Hi experts,

I'm working on a SOAP - XI - R3(RFC) scenario. I use 4 RFC's all of them with the same communication channel (RFC-ADAPTER). This worked fine for several months but know there's one incidence.

One of the RFC's has been changed and when it's called from the SOAP side I get this error, I see three entries on XI SXMB_MONI (before when it worked there were just two entries, request+response):

- One entrie with icon grey circle and message log version

- Next entrie with red circle and RFC_ADAPTER error

- Last entrie with MESSAGE_MAPPING error (but I think this is because I have no mappings for exceptions)

One important question, when the function is executed without no data to return (just few miliseconds) the interface runs ok (two square flags...like formule 1)

When the function is executed with good data it takes 1 second and a half (just the ABAP code)and I find my error..

It seems as if the RFC ADAPTER couldn't wait for this time...our XI is 3.0 SP14...

Does anybody got this problem anytime?? I'm stuck with this...don't know what to do...

Please help!!!

Best regards.

Former Member

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question