Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Idoc Invoice without Delimiter " ' " after BIC conversion

Hi,

I sent an Invoice Idoc to a customer, but he isn't able to convert und process the data. As far as I know it is a problem of Segment separation. There are not ' in this message at the end of any segment. How can I force BIC to generate these separators ? Thanks in advance for any advice.

Torsten

Former Member replied

Hi,

you will need to use the parameter "destDelimiter".

Set this in the communication channel. If you want to set up different delimiters for each trading partner, you will need to replicate the communication channel one for each trading partner.

destDelimiter

Sets the destination Delimiter. You must use a String with the length of 6 characters.

The order of the delimiter is as follows:

subfield, field, decimal, quoting, fieldgroup, segment

Also you have the possibility to change the delimiters directly in your 1:1 X2E mapping in the bic designer. For this you have to open the mapping and at the destination options you set the flag and then you can change the settings at setDestinationDelimiters.

Hope i could help

ilka

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question