Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

trans.log file showing 'ERROR => CONNECT failed with sql error 12541'

Dear All

We have upgraded our datatabse from Oracle 9.2.0.8 to Oracel 10.2.0.4 on our ECC 5.0 IS-AFS SAP system. When we check version from SQL, it's showing 10.2.0.4. That means database is successfully upgraded. Now, when we login through our <SID>adm user and checking R3trans -d, it is showing

'This is R3trans version 6.13 (release 640 - 07.01.08 - 14:25:00).

unicode enabled version

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'V

AP'"

R3trans finished (0012).'

In the trans.log file it is showing,

4 ETW000 R3trans version 6.13 (release 640 - 07.01.08 - 14:25:00).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 22.06.2009 - 11:56:40

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: R3trans -d

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [dev trc ,00000] Mon Jun 22 11:56:40 2009 110 0.000

110

4 ETW000 [dev trc ,00000] db_con_init called 27 0.000

137

4 ETW000 [dev trc ,00000] create_con (con_name=R/3) 62 0.000

199

4 ETW000 [dev trc ,00000] Loading DB library '/usr/sap/VAP/SYS/exe/run/dboraslib.o' ...

4 ETW000 77 0.000

276

4 ETW000 [dev trc ,00000] load shared library (/usr/sap/VAP/SYS/exe/run/dboraslib.o), hdl

0

4 ETW000 8142 0.008

418

4 ETW000 [dev trc ,00000] Library '/usr/sap/VAP/SYS/exe/run/dboraslib.o' loaded

4 ETW000 43 0.008

461

4 ETW000 [dev trc ,00000] function DbSlExpFuns loaded from library /usr/sap/VAP/SYS/exe/r

un/dboraslib.o

4 ETW000 61 0.008

522

4 ETW000 [dev trc ,00000] Version of '/usr/sap/VAP/SYS/exe/run/dboraslib.o' is "640.00",

patchlevel (0.276)

4 ETW000 421 0.008

943

4 ETW000 [dev trc ,00000] function dsql_db_init loaded from library /usr/sap/VAP/SYS/exe/

run/dboraslib.o

4 ETW000 46 0.008

989

4 ETW000 [dev trc ,00000] function dbdd_exp_funs loaded from library /usr/sap/VAP/SYS/exe

/run/dboraslib.o

4 ETW000 75 0.009

064

4 ETW000 [dev trc ,00000] New connection 0 created 48 0.009

112

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = -000000001 state = DISCONNECTED, perm =

YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 53 0.009

165

4 ETW000 [dev trc ,00000] db_con_connect (con_name=R/3) 55 0.009

220

4 ETW000 [dev trc ,00000] find_con_by_name found the following connection for reuse:

4 ETW000 53 0.009

273

4 ETW000 [dev trc ,00000] 0: name = R/3, con_id = 000000000 state = DISCONNECTED, perm =

YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 49 0.009

322

4 ETW000 [dev trc ,00000] Got ORACLE_HOME=/oracle/VAP/102_64 from environment

4 ETW000 521 0.009

843

4 ETW000 [dev trc ,00000] -->oci_initialize (con_hdl=0) 84 0.009

927

4 ETW000 [dev trc ,00000] got NLS_LANG='AMERICAN_AMERICA.UTF8' from environment

4 ETW000 65 0.009

992

4 ETW000 [dev trc ,00000] Client NLS settings: AMERICAN_AMERICA.UTF8 2033 0.012

025

4 ETW000 [dev trc ,00000] Logon as OPS$-user to get SAPVAP's password 49 0.012

074

4 ETW000 [dev trc ,00000] Connecting as /@VAP on connection 0 (nls_hdl 0) ... (dbsl 640 1

80309)

4 ETW000 57 0.012

131

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet C

EnvHp ErrHp ErrHpBatch

4 ETW000 49 0.012

180

4 ETW000 [dev trc ,00000] 0 UTF8 1

0x1113a4400 0x1113b6b00 0x1113b63b8

4 ETW000 58 0.012

238

4 ETW000 [dev trc ,00000] Allocating service context handle for con_hdl=0 48 0.012

286

4 ETW000 [dev trc ,00000] Allocating server context handle 42 0.012

328

4 ETW000 [dev trc ,00000] Attaching to DB Server VAP (con_hdl=0,svchp=0x1113b97d8,srvhp=0

x1113b99f8)

4 ETW000 95 0.012

423

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCIServerAttach' failed: rc = 12541

4 ETW000 4556 0.016

979

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error 12541.

4 ETW000 59 0.017

038

4 ETW000 [dev trc ,00000] set_ocica() -> OCI or SQL return code 12541 39 0.017

077

4 ETW000 [dev trc ,00000] Try to connect with default password 184 0.017

261

4 ETW000 [dev trc ,00000] Connecting as SAPVAP/<pwd>@VAP on connection 0 (nls_hdl 0) ...

(dbsl 640 180309)

4 ETW000 46 0.017

307

4 ETW000 [dev trc ,00000] Nls CharacterSet NationalCharSet C

EnvHp ErrHp ErrHpBatch

4 ETW000 48 0.017

355

4 ETW000 [dev trc ,00000] 0 UTF8 1

0x1113a4400 0x1113b6b00 0x1113b63b8

4 ETW000 48 0.017

403

4 ETW000 [dev trc ,00000] server_detach(con_hdl=0,stale=0,svrhp=0x1113b99f8)

4 ETW000 54 0.017

457

4 ETW000 [dev trc ,00000] Detaching from DB Server (con_hdl=0,svchp=0x1113b97d8,srvhp=0x1

113b99f8)

4 ETW000 54 0.017

511

4 ETW000 [dev trc ,00000] Deallocating server context handle 0x1113b99f8 42 0.017

553

4 ETW000 [dev trc ,00000] Allocating server context handle 33 0.017

586

4 ETW000 [dev trc ,00000] Attaching to DB Server VAP (con_hdl=0,svchp=0x1113b97d8,srvhp=0

x1113b99f8)

4 ETW000 54 0.017

640

4 ETW000 [dboci.c ,00000] *** ERROR => OCI-call 'OCIServerAttach' failed: rc = 12541

4 ETW000 2547 0.020

187

4 ETW000 [dbsloci. ,00000] *** ERROR => CONNECT failed with sql error 12541.

4 ETW000 45 0.020

232

4 ETW000 [dev trc ,00000] set_ocica() -> OCI or SQL return code 12541 28 0.020

260

4 ETW000 [dblink ,00428] ***LOG BY2=>sql error 12541 performing CON [dblink#3 @ 428]

4 ETW000 220 0.020

480

4 ETW000 [dblink ,00428] ***LOG BY0=>ORA-12541: TNS:no listener [dblink#3 @ 428]

4 ETW000 42 0.020

522

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'V

AP'"

Checked the listener service. It is already started and status is OK. Please help.

Regards

Shashank Shekhar

Former Member
Not what you were looking for? View more on this topic or Ask a question