Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Error in "Run Java migration toolkit", doing a SAP system copy.

Hi all,

Migration to new hardware with system copy, get an error in CI installation on "Run Java Migration Toolkit".

From the sapinst.log:

ERROR 2009-05-13 12:46:47.188

FJS-00003 TypeError: ci.getInstanceDir() has no properties (in script NW_Doublestack_CI|ind|ind|ind|ind, line 120276: ???)

ERROR 2009-05-13 12:46:48.318

FCO-00011 The step InitPrivateContext with step key |NW_Doublestack_CI|ind|ind|ind|ind|0|0|NW_CI_Instance|ind|ind|ind|ind|12|0|NW_CI_Instance_Configure_Java|ind|ind|ind|ind|4|0|NW_RUN_MIGRATION_CONTROLLER|ind|ind|ind|ind|2|0|InitPrivateContext was executed with status ERROR .

From the sapinst_dev.log:

ERROR 2009-05-13 12:46:47.188 [iaxxejsbas.cpp:204]

FJS-00003 TypeError: ci.getInstanceDir() has no properties (in script NW_Doublestack_CI|ind|ind|ind|ind, line 120276: ???)

TRACE 2009-05-13 12:46:48.038 [syuxctask.cpp:1382]

CSyTaskImpl::start(bool)

A child process has been started. Pid = 23620

ERROR 2009-05-13 12:46:48.318 [sixxcstepexecute.cpp:951]

FCO-00011 The step InitPrivateContext with step key |NW_Doublestack_CI|ind|ind|ind|ind|0|0|NW_CI_Instance|ind|ind|ind|ind|12|0|NW_CI_Instance_Configure_Java|ind|ind|ind|ind|4|0|NW_RUN_MIGRATION_CONTROLLER|ind|ind|ind|ind|2|0|InitPrivateContext was executed with status ERROR .

TRACE 2009-05-13 12:46:48.368 [iaxxgenimp.cpp:752]

CGuiEngineImp::showMessageBox

<html> <head> </head> <body> <p> An error occurred while processing service SAP NetWeaver 7.0 Support Release 3 > Software Life-Cycle Options > System Copy > Oracle > Target System Installation > High-Availability System > Based on AS ABAP and AS Java > Central Instance . You may now </p> <ul> <li> choose <i>Retry</i> to repeat the current step. </li> <li> choose <i>View Log</i> to get more information about the error. </li> <li> stop the task and continue with it later. </li> </ul> <p> Log files are written to /tmp/sapinst_instdir/NW04S/LM/COPY/ORA/SYSTEM/HA/AS/CI. </p> </body></html>

TRACE 2009-05-13 12:46:48.368 [iaxxgenimp.cpp:1255]

CGuiEngineImp::acceptAnswerForBlockingRequest

Waiting for an answer from GUI

I had checked the INSTANCE_NAME parameter, in every profile, and is ok.

I tried a new instalation, after importing the profiles, and checking the INSTANCE_NAME, but got the same error.

Please, advice.

Thanks in advance.

Best Regards.

Jorge

Tags:
Not what you were looking for? View more on this topic or Ask a question