Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Duplicating subtree problems with imported definitions

Hi there!

I have a really serious problem: We've built complex XSD definitions for processing EDI messages through XI. Now, we're about to map IDocs to our generated XSD's. Sometimes it's necessary to use the "Duplicate Subtree" functionality in the target message in order to ensure correct mapping.

e.g.

Duplicating Node ORDERS/G00/DTM to map it twice

But when I try to save my work, I get always the same error message which also deletes my whole mapping work. The message is like this:

The source or target structure has been changed or could not be found in the Integration Repository. The mapping definition contains elements or attributes that do not exist in the changed structure. The relevant entries will be deleted

Target structure has no such path: /ORDERS/G00/DTM[1]/@D_Segment_tag. Skipping mapping

I tried both - importing the definition directly into the mapping - and importing the xsd to a datatype and wrap it by a message type. The xsd facets also match this multiple occurance. It seems, that XI cannot assign the index "[1]" back to the XSD.

Is there any hint to solve this issue? Help is higly appreciated!!!

Cheers,

Matthias

Former Member
Not what you were looking for? View more on this topic or Ask a question