Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

ITS development problems (templates)

Hello,

I am developing an Internet service based on a SAP transaction using the Internal ITS on 6.40. I have followed the Weblog (Running your first ITS WebGUI application in SAP Netweaver 04 ABAB Edition, /people/durairaj.athavanraja/blog/2005/08/21/running-your-first-its-webgui-application-in-sap-netweaver-04-abap-edition--nsp).

There is no problems web enabling a transaction as long as the generatedynpro is set to 1. But when I try to create my own theme and template, I cannot seem to get the transaction to use the templates I have created.

When I set generatedynpro to 0, I get an error stating: ITS_TEMPLATE_NOT_FOUND (described in Workflow on Intergrated ITS - dialog work items will not execute). The table which are referenced seems to contain the right content. I have read the related note as well without luck.

I have tried to keep ~genereatedynpro 1 and used the ~template MYTEMPLATE to force the loading of my template, as generatedynrpo is supposed to use a template if it exsists.

Anyone have an idea, on how I can get the transaction to use my created temple while still keep the ITS_TEMPLATE_NOT_FOUND error away? (or better solve the error).

Best regards,

Joe

replied

Hi Joe,

make sure that ~theme is correctly set in the service definition in ICF. Otherwise integrated ITS will not find the templates.

Best regards,

Klaus

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question