Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

BAPI result cached

I call a BAPI to update the record and the record is updated in the backend. But when I call the record finder BAPI it still returns the old non-updated record. Say I refresh the browser and then execute the finder BAPI it returns the updated record. So it appears that the finder BAPI is caching it for performance. Any idea how to disable this? Thanks!

Former Member
replied

Hi Ashish,

You have to disable dataservice cache, in the VC storyboard:

Tools -> Options -> Compiler -> Data service retrieval

there change your option to

"Do not cache data services (get latest)"

And re-compile/deploy your model...

Best Regards,

Luis

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question