Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Failed to fill the prompts when creating Webi Report

Hi,

I am having some difficulties when I was trying to creating Webi reports. It shows error when I tried to fill in the prompts before the query runs. The report data comes from the SAP Business Warehouse. So far it is my understanding for the query flow:

Step 1

SAP Business Warehouse <-- Query A (BW Query) <--

Step 2

BO Universe <-- Query B (By drag & drop) <-- Application(e.g. Webi, QaaWS)

When I run the Query A (using 'Analyzer' in 'Business Explorer') to extract data from BW, the query appears 7 optional parameters for filtering. After I filled some of the fields, the query runs fine -> Step 1 OK.

When I want to do the same thing in a BO approach by building query (i.e. Query B) to draw data from the universe (which points to the Query A in BW) using different applications(e.g. QaaWS, Webi via InfoViewApp, Java Webservice SDK: QueryService & ReportEngine, etc), the application will display 7 optional prompts (i.e. those referring to those appeared in Query A) before the query executes. However, when I tried to fill those prompts, the application appears some fill prompts error and no query job is submitted to the BW -> Step 2 Fails.

When I skipped to fill those optional prompts in building the Query B, the query job can be submitted and the query result is returned.

I would like to ask how to avoid the error and what causes it. I feel so strange as the query job have been working fine for some weeks before this error suddenly appears a couple of days ago.

Also, please advise if this thread is placed in a correct place.

Many Thanks,

Gary

Not what you were looking for? View more on this topic or Ask a question