Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

CR9/Informix 7.4: "Not Supported" error

Hi All,

I've been racking my brain for the last day on this. I have a crystal report that has sub-reports, all data is collected from Informix stored procedures, but i'm receiving a very non-descript error "Not Supported" when trying to add any new subreports:

Main Report -> (storedproc_1)

--> SubReport (storedproc_2) Existing

--> SubReport2 (storedproc_3) Existing

--> SubReportNew (storedproc_4) NEW

When i run the above report, i get this "Not Supported" error pop-up about 4 times in a row on the page where SubReportNew is supposed to run. if i suppress this subreport it works fine and shows the first 2 subreports.

The Strange Part:

When i open the subreport and run it in isolation it works! Then if i run it from the main report it works fine. But once the document is closed and re-opened its back to not working.

When i put tracing on the stored procedure i find that Crystal isn't even calling it - it bombs out before that point.

Has anyone ever experienced this, or know how i can get more description on the error messages, is there a log somewhere with more detail?

Any help will be greatly appreciated.

Regards,

Trent

Not what you were looking for? View more on this topic or Ask a question