Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Server/Composition Environment Version Mismatch?

I have the "SAP NetWeaver 7.0 (2004s) - Trial Version on Linux" installed on a back end machine, and "SAP NetWeaver Composition Environment 7.1 SR5 - Trial Version" installed on Windows for the NW Developer Studio.

When I run and deploy a test application, I get the following messages. When I check on the server the packages are indeed missing. I suspect that the NWDS version exceeds the version on the server since it is 7.1, and the server is 7.0. Can someone confirm that and advise me on the best way to fix the problem?

Oct 7, 2008 2:49:53 PM   Error: Unresolved dependencies found for the following SDAs:

1.: development component 'teched167.ex1'/'demo.sap.com'/'localDevelopment'/'20081007144914'
dependency: 
       name:     'tc/bl/jrfc/api'
     vendor:     'sap.com'

dependency: 
       name:     'tc/wd/api'
     vendor:     'sap.com'

dependency: 
       name:     'tc/aii/base/offline/facade'
     vendor:     'sap.com'

dependency: 
       name:     'tc/bl/exception/lib'
     vendor:     'sap.com'

dependency: 
       name:     'tc/ddic/runtime/facade'
     vendor:     'sap.com'

dependency: 
       name:     'tc/bl/logging/api'
     vendor:     'sap.com'


Deployment will be aborted.
Oct 7, 2008 2:49:53 PM   Error: Prerequisites were aborted.
Oct 7, 2008 2:49:53 PM   Error: Error while creating deployment actions.

Former Member
Not what you were looking for? View more on this topic or Ask a question