Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Batch no range


I have maintained number range for batch_mat on material type. but while processing it is taking batch_clt nor range. Is there any assignment is there after creating nor range on material type.

Thank you


Former Member


When you go to OMAD

Here you get No. Range Object as "BATCH_CLT"

And no option for maintaining the Plant, Material Type, or any other field since this is at Client level.

Ask your ABAPer to create a new No. Range Object for Material Type level.

Use that No. Range Object in OMAD and once you click on "Number Ranges" button then you will get option of maintaining Material Type and No. Range both.

Note: - For OMAD

Standard settings

In the standard, number range 01 from 0000000001 to 9999999999 has been defined for number range object BATCH_CLT.


Check whether number range interval 01 exists and maintain new number ranges, if necessary.

Further notes

If you replace the number range object and/or interval proposed by the system with your own object or interval using customer function call EXIT_SAPLV01Z_001, maintain the number range object and/or interval in this step.

You can not create a no. range object by copying an existing one.

In OMAD, Create a no. range object

here input Subobject data element as MTART i.e. material type.



0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question