Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Reinstalling 2007A PL30

Dear All,

I intend to upgrade from 2007A PL30 to PL41 but while running upgrade common the following error message appears "connect database failed, may be you have not started your database!Please check your database status and try run this upgrade installer by manual" After clicking "OK" to continue. While login to database, another error stated "Application has problem with a dmp file created in log file and program automatically stopped. I uninstalled SAP program and reinstall PL 30. While database is selected and system auto starting XLR, the following error appear "Class does not support automation or does not support expected interface". Try to start other add on, none of it is working.

Any idea how to make my PL30 rework?

Regards

Thomas

replied

Hi Thomas Lai,

The XLR error issue you described seems to be related to a DI API version

mismatch. Please make sure that XL Reporter is using the same DI API version as the Business One client patch level:

However, if this does not resolve your issue, please reinstall the

Business One Client as XL Reporter is now a part of the core product

and can not be reinstalled separately.

In cases of run-time errors, a reinstallation of XLR will often

resolve the issue.

Van Xue

SAP Business One Forums Team

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question