Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Scheduled Report Failing - Don't Know Why

I'm trying to re-create a scheduled report on CMC that had gotten deleted. It ran before (sometimes multiple times...) but at least it ran. I'm duplicating all the settings for this report based on how they were before, but every time I try to get the report to run, it fails.

I don't know enough about this to be able to embed any kind of error messages in the e-mail notifications we get. All I know is that no matter what I change/tweak/adjust, we get an email saying "This report has failed to run."

What kinds of things should I be looking at to troubleshoot? I know the report itself is fine, as users can view it normally (as in, through other viewers). There's definitely something specific to the scheduling process that is not correct, but I don't know what to look at.

Here is how the scheduling is currently configured:

Schedule > Main Tab

-Run Weekly, Tues - Sat

-Start Date: 10/01/08, 8:30 AM (I originally set this up yesterday, so today at 8:30 should have been the first time it ran, but instead it failed)

-End Date: 10/01/18, 12:00 AM

-Number of retries allowed: 0

-Retry interval in seconds: 1800

Schedule > Notification

-Email notification based on: a job has failed to run

-Message: Report failed to run. Scheduled Report: %SI_NAME% - %SI_STARTTIME% What other codes can we put in this message, BTW? I've been trying to look for something to return error codes, but %SI_OUTCOME%, %SI_STATUSINFO%, and %SI_ALERT_MESSAGE% don't display anything, they just print on the email

Schedule > Destination

-Destination: Email (SMTP)

-Clean up instance after scheduling is checked

-We have "Set the values to be used at schedule time here:" populated with our list of email addresses for recipients

-Attach object instance to email message is checked

-Specified file name: %SI_NAME%%SI_STARTTIME%.%EXT%

-Add extension is checked

Schedule > Format

-Format: Microsoft Excel (Still fails if we choose Excel Data Only or Adobe Acrobat)

-Use options saved with report is checked (Still fails if we deselect this)

Schedule > Schedule For

-Schedule only for myself.

Could really use some help here, as I don't know what in the world could be causing this to fail. Thanks in advance.

replied

First thing is to forget all the complex configs and just try to schedule the report to run once now, no alerts, no notifications, no nothing.

Does that work?

Then you can build up the schedule, to see where the problem is coming from.

Sincerely,

Ted Ueda

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question