Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

R3 4.7 Installation Error

I'm installing R3 4.7x110 SR1 on Oracle/HP-UX. During the database load phase, I am stopped due to the following error:

sapparam: sapargv( argc, argv) has not been called.

sapparam(1c): No Profile used.

sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

ERROR 2008-10-01 12:50:27 [iaxxbdbld.cpp:1001]

CR3ldStep::startR3ldProcesses lib=iamodload module=CR3ldStep

MSC-01015 Process finished with error(s), check log file /sapinstall/DBI/SAPSSEXC.log

SAPSSEXC.log is not the only log file to be checked but almost all SAP*.log files. All the files have similar logs as below:

Wed Oct 1 12:48:54 2008

***LOG BY2=> sql error 12154 performing CON [dblink#1 @ 419] [dblink 0419 ]

***LOG BY0=> ORA-12154: TNS:could not resolve service name [dblink#1 @ 419] [dbl

ink 0419 ]

(DB) ERROR: db_connect rc = 256

DbSl Trace: Logon as OPS$-user to get SAPDV1's password

DbSl Trace: Connecting as /@DV1 on connection 0 ...

DbSl Trace: Attaching to DB Server DV1 (con_hdl=0,svchp=600000000083def0,svrhp=6

0000000009cbd48)

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12154

DbSl Trace: CONNECT failed with sql error '12154'

DbSl Trace: Try to connect with default password

DbSl Trace: Connecting as SAPDV1/<pwd>@DV1 on connection 0 ...

DbSl Trace: Attaching to DB Server DV1 (con_hdl=0,svchp=600000000083def0,svrhp=6

0000000009d9258)

DbSl Trace: OCI-call 'OCIServerAttach' failed: rc = 12154

DbSl Trace: CONNECT failed with sql error '12154'

(DB) ERROR: DbSlErrorMsg rc = 99

/sapmnt/DV1/exe/R3load: job finished with 1 error(s)

/sapmnt/DV1/exe/R3load: END OF LOG: 20081001124854

Because it appears to be a problem with the DB, I tried to startup from sqlplus. Afterwards, I checked the processes that are running but it lacks oracleDV1 process. (The listener is up inherited from another syste as I have multiple oracle homes)

  1. ps -ef|grep dv1

oradv1 10033 1 0 12:29:41 ? 0:00 ora_arc0_DV1

oradv1 10031 1 0 12:29:41 ? 0:00 ora_reco_DV1

root 10398 10359 0 12:33:53 pts/ta 0:00 grep DV1

oradv1 10011 1 0 12:29:40 ? 0:00 ora_pmon_DV1

oradv1 10027 1 0 12:29:41 ? 0:00 ora_ckpt_DV1

oradv1 10029 1 0 12:29:41 ? 0:00 ora_smon_DV1

oradv1 10035 1 0 12:29:41 ? 0:00 ora_arc1_DV1

oradv1 10017 1 0 12:29:41 ? 0:00 ora_dbw0_DV1

oradv1 10025 1 0 12:29:41 ? 0:00 ora_lgwr_DV1

I tried to execute startdb but the following error is listed:

$ startdb

Trying to start database ...

Log file: /home/oraDV1/startdb.log

/usr/sap/DV1/SYS/exe/run/startdb: Terminating with error code

$ more startdb.log

-


Wed Oct 1 12:39:26 EAT 2008

LOGFILE FOR STARTING ORACLE

Trying to start DV1 database ...

-


Wed Oct 1 12:39:26 EAT 2008

checking required environment variables

ORACLE_HOME is >/oracle/DV1/920_64<

ORACLE_SID is >DV1<

-


Wed Oct 1 12:39:26 EAT 2008

check initora

-


Wed Oct 1 12:39:26 EAT 2008

check initora

-


Wed Oct 1 12:39:26 EAT 2008

starting orasrv

/oracle/DV1/920_64/bin/orasrv missing or without set-user-ID bit. Terminating.

/usr/sap/DV1/SYS/exe/run/startdb: Terminating with error code

Can anyone help me so that I can proceed with my installation?

Thanks!

Not what you were looking for? View more on this topic or Ask a question