Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Client tools not authenticating via Windows AD after upgrade to SP4

We recently upgraded our test environment to SP4 to correct a problem we were having with Windows AD authentication from InfoView. The upgrade to SP4 and JDK 1.5 solved our InfoView problem, but our client tools (Designer, Desk, Crystal Reports) can no longer login to our test environment using Windows AD authentication.

The error message we get when trying to connect to the SP4 instance using Designer or Deski is as follows:

[repo_proxy 13] SessionFacade::openSessionLogon with user info has failed(Internal error.(hr=#0x80042a01)

Enterprise authentication continues to work as normal. My first thought was that my client tools are at the SP2 level and they are trying to connect to an SP4 instance. Therefore, I need to upgrade the client tools to the SP4 level as well in order to get Windows AD authentication to work. Is this correct, and if so what is the proper way to upgrade the client tools to SP4?

On the SAP download site you can download the SP4 Full install, but when you run it says to uninstall the existing version first which I haven't tried yet. Does the SP4 full install give the option to do a client install versus a server install like previous SP2 install?

replied

While we always recommend matching versions I have rarely seen a problem with client tools and AD using different versions. I think you may have a different issue.

If your clients were installed from a deski/designer ONLY install then you can use a client version of SP4 that is much smaller. There should also be a server version that can be installed on top of deski/designer+ client tools (this should not require an uninstall). Finally there is an integrated build which includes the full XIR2 product with SP4 built in(it sounds like you downloaded this).

If SP4 does not resolve I'd suggest opening a message with support and packet scanning the client with netmon or wireshark.

What's the error you get with crystal using AD? There was a known issue on SP3 client patch that made all clients fail with AD/LDAP.

Regards,

Tim

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question