Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Unable to install Java Support Packages with JSPM or SDM

I am trying to update the support package stack from 14 to 16 on my Netweaver 2004s system. I was able to update the JSPM by itself from 14 to 16 but after trying and failing to install the reamainder of the support packages I now get the following error after logging into JSPM.

Trouble Ticket Report

Java Support Package Manager for SAP NetWeaver'04s

SID................: MDE

Hostname...........: livadmmiimde

Install directory..: E:/usr/sap/MDE

Database...........: Microsoft SQL Server

Operating System...: $(/J2EE/StandardSystem/CentralInstance/J2EEEngineInstanceHost/OpSysType)

JDK version........: 1.4.2_18 Sun Microsystems Inc.

JSPM version.......: 7.00.16.0.19

System release.....: 700

ABAP stack present.: true

The execution ended in error.

com.sap.sdt.util.diag.DevelopmentSupportRequiredException: Assertion failed for (Cannot find AAS usage in all usages array. Possible reason: It wasn't defined with the same name in UsageDefinition file) at com.sap.sdt.util.diag.SDT.check(SDT.java:36).

More information can be found in the log file E:\usr\sap\MDE\DVEBMGS00\j2ee\JSPM\log\log_2008_09_30_10_34_44\JSPM_MAIN_1_01.LOG.

Use the information provided to trouble-shoot the problem. There might be an OSS note providing a solution to this problem. Search for OSS notes with the following search terms:

com.sap.sdt.jspm.phases.PhaseTypeJSPM

com.sap.sdt.util.diag.JavaException

com.sap.sdt.util.diag.DevelopmentSupportRequiredException: Assertion failed for (Cannot find AAS usage in all usages array. Possible reason: It wasn't defined with the same name in UsageDefinition file) at com.sap.sdt.util.diag.SDT.check(SDT.java:36).

JSPM_MAIN

JSPMPhases

Java Support Package Manager

I then tried to perform the single package install with SDM on the ones that I can't get installed and I am still running into the same errors. Since I wasn't sure if I did something wrong or not, I went and created another server and installed the same software at the same levels and then tried to patch again and it is failing in exactly the same way. I was told by SAP Support to put on the java package sap_jtechs first and then do the rest but I get the error on that patch immediately. I receive the error on the sap_jtechs package on both server during the deployment of area com.sap.engine.heartbeat. I am running this on Windows 2003 Server using 64-bit binaries. I was able to install this patch on our AIX installation without any issues so I am wondering if my java is what is causing my problem or not. I am running java 1.4.2_18 AMD 64-bit. I have been able to apply about 20 patches successfully on the 1st server at this point. Please let me know if there are any ideas on what I can do to get around the problem. I have opened a message to SAP but I have not heard anything back in about 5 days now. Thanks.

Not what you were looking for? View more on this topic or Ask a question