Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Installing SAPGUI 7.10 on vista sp1 through network does not register files

I am trying to install sapgui 71.0 patch level 7 on a vista sp1 machine, using network sap distribution service

. But the ocs and dll files won't register.

In the sap installation errorlog there are -2147024893 messages for all ocx en dll files.

When I look in the windows log files there is a sidebyside message (translated from dutch):

Can not make activationcontext for 'C:\Program Files\SAP\FrontEnd\SAPgui\sapshlib.dll' . Can not find dependend assembly Microsoft.VC80.MFC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.762" .

Manualy installing these files as an local administrator gives the same error results.

So I think there is a problem with C++ libraries deployement.

I have tested this on several Vista SP1 pc's with the same error result.

Any ideas how to resolve this?

Not what you were looking for? View more on this topic or Ask a question