Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Errors while running MAU application in a PDA

Hi All,

We have customized ZMAU and after checking the u2018Add JSP as complied classesu2019 u2013 We are deploying that application on a PDA with OS = WM 6.0

Crème = CrEme329_ARM_CE42_PPC.exe

DB2E 9.22

The application is successfully deployed. When we click on the application name, The Page not found error is there.

But when I access this link in the explorer in PDA: http://localhost:4444/ZMAU/mam_start.jsp,

The application MAU home page is displayed. When we click on Technical Object Management, we can see the list of Equipments, But then clicking on one particular Equipment No, we get the following error

Error: 500

Location: /ZMAU/techobj/techobj_equipment_details.jspInternal Servlet Error:

javax.servlet.ServletException: cannot find message associated with key : dispatcher.forwardException

at org.apache.tomcat.facade.RequestDispatcherImpl.doForward()

at org.apache.tomcat.facade.RequestDispatcherImpl.forward()

at com.sap.ip.me.api.runtime.jsp.AbstractMEHttpServlet.dispatchRequest()

at com.sap.ip.me.api.runtime.jsp.AbstractMEHttpServlet.doGetNotThreadSafe()

at com.sap.ip.me.api.runtime.jsp.AbstractMEHttpServlet.doGet()

at javax.servlet.http.HttpServlet.service()

at com.sap.ip.me.api.runtime.jsp.AbstractMEHttpServlet.service()

at javax.servlet.http.HttpServlet.service()

at org.apache.tomcat.core.ServletWrapper.doService()

at org.apache.tomcat.core.Handler.service()

at org.apache.tomcat.core.ServletWrapper.service()

at org.apache.tomcat.core.ContextManager.internalService()

at org.apache.tomcat.core.ContextManager.service()

at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection()

at org.apache.tomcat.service.TcpWorkerThread.runIt()

at org.apache.tomcat.util.ThreadPool$ControlRunnable.run()

at java.lang.Thread.run()

(A similar error occurs when we Click on Order Management and then a particular order.)

Same thing runs perfectly on Laptop client, except the previous u2013 Page not found error which comes when you click on the Application name in the MI home page)

So there are two issues as you must have noticed. Please provide the solution or hints to solve the problem.

Thanks and Regards

Neha Mahanty

Not what you were looking for? View more on this topic or Ask a question