Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Database initialization failed after attach the database.

Hello Everyone,

I have a problem after detaching the database and attaching it again (I moved the database to another partition because of shortage of disk space). Then, I find that the system can not start. (I've two systems and now neither of them could start). The error seems very similar.

In the pure java system(netweaver 04s) log: jvm_bootstrap.out,

com.sap.engine.bootstrap.synchronizationException: Database Initializtion Failed! Check database properties.

..........

..........

com.sap.engine.frame.core.configuration.configurationException: Error while connecting to DB.

.......

........

Caused by: java.sql.SQLException: [NWMss] [SQLServer JDBC Driver] [SQLServer] Login failed for user 'SAPBP0DB'.

...........

..........

In pure ABAP system(Netweaver 04s) log: dev_w12:

openoledbConnection: MARS property was not set.

openoledbConnection: line 23722. hr: 0x8000ffff login failed for user 'CNDT50083414\SAPServiceBE0'.

sloledb.cpp [openoledbConnection, line 23722]: Error/Message: (err 18456, sev 0), Login failed for user 'CNDT50083414\SAPServiceBE0'.

..........

sloledb.cpp [openoledbConnection, line 23722]: Error/Message: (err 0, sev 0), Invalid string connection attribute.

..............

Is this because the DB not started? In Windows Services, I found 'MSSQLServer' is started.

How can I trace down to this problem? I don't have much idea on DB...

All your kindly help is greatly appreciated.

Best Regards,

Not what you were looking for? View more on this topic or Ask a question